Company-Wide Meeting
Incident Report for Volusion
Resolved
Our Meeting is over and the Support team is available to assist you.
Posted 9 days ago. Jan 11, 2019 - 11:10 CST
Investigating
We are hosting a company-wide meeting between 9:00am CST to 10:30am CST. During this time our phone services will be unavailable, but our in-app messenger will remain open. We appreciate your patience along with providing us the ability to meet as a team.
Posted 9 days ago. Jan 11, 2019 - 08:38 CST
This incident affected: Support.