Company Wide Meeting
Incident Report for Volusion
Resolved
Our meeting has resolved and our phone lines are back open. Thank you for your patience.
Posted Dec 18, 2020 - 10:31 CST
Identified
We are hosting a company-wide meeting between 9:15am CST to 10:45am CST. During this time our phone services will be unavailable however our In-app messenger will remain active. We appreciate your patience along with providing us the ability to meet as a team.
Posted Dec 18, 2020 - 08:32 CST
This incident affected: Volusion Platform (Merchant Dashboard).