Department Wide Meeting
Incident Report for Volusion
Resolved
Our Support phones have been reopened and we are here to assist you.
Posted Dec 08, 2020 - 16:13 CST
Identified
Our Support department will be attending a Department Wide meeting this afternoon and due to this our phone queues will be closed from 2:45pm CST to 4:15pm CST on Tuesday, December 8th, 2020. Our Live chat platform will remain open for the duration of the meeting. Thank you for your understanding.
Posted Dec 08, 2020 - 14:43 CST
This incident affected: V1 (V1 - Support).