Company-wide Meeting
Incident Report for Volusion
Resolved
Company wide meeting has concluded and phone services are available.
Posted 2 months ago. Oct 12, 2018 - 10:40 CDT
Identified
We are hosting a company-wide meeting between 9:00am CST to 10:30am CST. During this time our phone services will be unavailable, but our in-app messenger will remain open. We appreciate your patience along with providing us the ability to meet as a team.
Posted 2 months ago. Oct 12, 2018 - 08:11 CDT
This incident affected: Support.