Company Holiday Party - Early Phone Support Closing Time
Incident Report for Volusion
Resolved
The Holiday party is over and phone support will commence with the normal scheduled times.
Posted Dec 09, 2018 - 00:50 CST
Investigating
In celebration of the upcoming Holidays Volusion will be hosting our Annual Holiday Party. Phone Support will be closing early at 5:00pm but our Live Chat Service will remain operational to provide Support as normal. Thank you for your time and understanding.
Posted Dec 08, 2018 - 14:01 CST
This incident affected: Volusion Platform (Merchant Dashboard).