Email Notification Degraded State
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted 15 days ago. Aug 01, 2018 - 16:10 CDT
Identified
We are experiencing some issues with our email notifications. We've identified the root cause and working towards a solution. We will post updates as soon as they are available.
Posted 16 days ago. Jul 31, 2018 - 10:04 CDT
This incident affected: E-mail Services.