Support Department Meeting
Incident Report for Volusion
Resolved
Our Customer Experience team is back from their meeting. Please feel free to resume using the phone system at this time.
Posted Feb 12, 2019 - 13:35 CST
Identified
We are hosting a meeting for our Customer Experience team between 12:30 pm CST to 1:45 pm CST. During this time our Billing and Support team will be unavailable. We appreciate your patience along with providing us the ability to meet as a team.
Posted Feb 12, 2019 - 11:55 CST
This incident affected: Volusion Platform (Merchant Dashboard).