Slowness
Incident Report for Volusion
Resolved
There have been no new reports of the slowness issue occurring. This issue is now considered resolved.
Posted 6 months ago. Mar 13, 2018 - 00:02 CDT
Investigating
Some stores may be experiencing intermittent slowness with 504 errors. We are investigating.
Posted 6 months ago. Mar 12, 2018 - 21:44 CDT