Company Wide Meeting
Incident Report for Volusion
Resolved
Thank you. Our team is back and ready to assist.
Posted 8 days ago. Jan 12, 2018 - 10:46 CST
Identified
We are hosting a company-wide meeting between 9:15am CST to 10:45am CST. During this time our phone services will be unavailable, but our in-app messenger will remain open. We appreciate your patience along with providing us the ability to meet as a team.
Posted 8 days ago. Jan 12, 2018 - 08:28 CST