Company Wide Meeting
Incident Report for Volusion
Resolved
Our phone queues are back up and we are ready to help you with any questions you have!
Posted 6 months ago. Jun 09, 2017 - 10:46 CDT
Identified
We are hosting a company-wide meeting between 9:00am CST to 10:45am CST. During this time our phone services will be unavailable, but we will have a handful of reps available to assist via Intercom. We appreciate your patience along with providing us the ability to meet as a team.
Posted 6 months ago. Jun 09, 2017 - 08:49 CDT