Customer Experience Team Meeting
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted Mar 22, 2017 - 16:13 CDT
Identified
We are having a meeting for our Customer Experience team between 2:00pm CST to 4:00pm CST. During this time our phone and chat services will be unavailable. We appreciate your patience and providing us the ability to meet as a team.
Posted Mar 22, 2017 - 14:11 CDT