Webmail SSL Issue
Incident Report for Volusion
Resolved
Customers are able to access their mail by visiting mail.volusion.com or mail.yourdomainname.com. If you have any further questions, please contact our support department.
Posted Nov 08, 2017 - 18:34 CST
Identified
We have identified the issue regarding an insecure message when using webmail.volusion.com. Please continue to use mail.volusion.com and once this is resolved, we will update this status page.
Posted Nov 06, 2017 - 19:12 CST
Investigating
We are currently investigating an issue where webmail.volusion.com shows that the page is insecure. Please use mail.volusion.com in the meantime. We will provide an update when one is available.
Posted Nov 06, 2017 - 13:59 CST