MyVolusion password reset issues
Incident Report for Volusion
Resolved
The missing captcha when resetting your password in MyVolusion has been restored.
Posted 3 months ago. Mar 12, 2018 - 14:23 CDT
Investigating
We have discovered an issue where the captcha is missing from the MyVolusion password reset page, preventing customers from being to able to reset their passwords. We are currently investigating this issue and will offer updates as they arise.
Posted 3 months ago. Mar 10, 2018 - 22:52 CST