Company Wide Meeting
Incident Report for Volusion
Resolved
Thank you for your patience. Our teams are back and online ready to help!
Posted 5 months ago. May 12, 2017 - 10:43 CDT
Identified
We are hosting a company-wide meeting between 9:00am CST to 11:00am CST. During this time our phone and chat services will be unavailable. We appreciate your patience along with providing us the ability to meet as a team.
Posted 5 months ago. May 12, 2017 - 09:22 CDT