Company-Wide Meeting
Incident Report for Volusion
Resolved
Our Meeting is over and the Support team is available to assist you.
Posted Feb 15, 2019 - 10:34 CST
Identified
We are hosting a company-wide meeting between 9:45am CST to 10:30am CST. During this time our phone services will be unavailable, but our in-app messenger will remain open. We appreciate your patience along with providing us the ability to meet as a team.
Posted Feb 15, 2019 - 09:36 CST
This incident affected: Volusion Platform (Merchant Dashboard).