Company-wide Meeting
Incident Report for Volusion
Resolved
Our meeting is over, and we have reopened our queues.
Posted 5 months ago. Dec 14, 2018 - 10:35 CST
Identified
We are hosting a company-wide meeting between 9:00am CST to 10:30am CST. During this time our phone services will be unavailable, but our in-app messenger will remain open. We appreciate your patience along with providing us the ability to meet as a team.
Posted 5 months ago. Dec 14, 2018 - 08:58 CST
This incident affected: Support.