Check out Issues in Firefox
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted 21 days ago. Sep 27, 2018 - 13:06 CDT
Monitoring
The issue has been identified, and a fix has been implemented. We are continuing to monitor the issue.
Posted 21 days ago. Sep 27, 2018 - 07:32 CDT
Investigating
We are aware of an issue causing errors on the check out page when using Firefox. We're investigating the situation and will provide an update as soon as possible.
Posted 22 days ago. Sep 27, 2018 - 06:55 CDT
This incident affected: Merchant Storefront.