Company-wide Meeting
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 09, 2018 - 11:23 CST
Update
Phone lines are open again.
Posted about 1 month ago. Nov 09, 2018 - 10:31 CST
Identified
We are hosting a company-wide meeting between 9:00am CST to 10:30am CST. During this time our phone services will be unavailable, but our in-app messenger will remain open. We appreciate your patience along with providing us the ability to meet as a team.
Posted about 1 month ago. Nov 09, 2018 - 08:23 CST
This incident affected: Support.