Phone System Issue
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted Dec 28, 2020 - 15:15 CST
Investigating
We are currently experiencing some technical issues with our phone system. If you are in need of technical assistance, please start a chat with us from your admin dashboard by hovering over 'get help' in the upper right corner. We will provide an update once the issue has been resolved.
Posted Dec 28, 2020 - 14:08 CST
This incident affected: Volusion Platform (Merchant Dashboard).