help.volusion.com and helpcenter.volusion.com are down
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted 30 days ago. Nov 14, 2018 - 13:54 CST
Monitoring
help.volusion.com and helpcenter.volusion.com are back up, we will continue to monitor these sites.
Posted about 1 month ago. Nov 12, 2018 - 06:48 CST
Investigating
We are currently investigating an issue with help.volusion.com and helpcenter.volusion.com timing out
Posted about 1 month ago. Nov 12, 2018 - 06:20 CST