Company-wide Meeting
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 14, 2018 - 10:46 CDT
Update
We are continuing to investigate this issue.
Posted 2 months ago. Sep 14, 2018 - 10:46 CDT
Investigating
We are hosting a company-wide meeting between 9:00am CST to 10:30am CST. During this time our phone services will be unavailable, but our in-app messenger will remain open. We appreciate your patience along with providing us the ability to meet as a team.
Posted 2 months ago. Sep 14, 2018 - 08:14 CDT
This incident affected: Support.