Company Wide Meeting
Incident Report for Volusion
Resolved
Our company wide meeting has ended and our operations have resumed as normal. We thank you for your patience!
Posted 11 months ago. Nov 10, 2017 - 10:48 CST
Investigating
We are hosting a company-wide meeting between 9:15am CST to 10:45am CST. During this time our phone services will be unavailable, but our in-app messenger will remain open. We appreciate your patience along with providing us the ability to meet as a team.
Posted 11 months ago. Nov 10, 2017 - 09:07 CST