Company Wide Meeting
Incident Report for Volusion
Resolved
Our Support team is finished with their meeting and are back and ready to assist.
Posted Jan 17, 2020 - 11:56 CST
Identified
We are hosting a company-wide meeting between 9:15am CST to 11:45am CST. During this time our phone and in-app messenger services will be unavailable. We appreciate your patience along with providing us the ability to meet as a team.
Posted Jan 17, 2020 - 09:04 CST
This incident affected: Volusion Platform (Merchant Dashboard).