Company Wide Meeting 6/14/19
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 14, 2019 - 11:47 CDT
Identified
We are hosting a company-wide meeting between 9:30am CST to 11:30am CST. During this time our phone services will be unavailable, but our in-app messenger will remain open. We appreciate your patience along with providing us the ability to meet as a team.
Posted 4 months ago. Jun 14, 2019 - 09:09 CDT
This incident affected: V1 (V1 - Support).