Customer Experience Team Outing
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted Sep 05, 2018 - 16:45 CDT
Identified
Our Technical Support will be unavailable from 12pm - 5pm CDT for a team outing.

Members from other Volusion departments are going to be available to help with your questions until the support team returns.

Our Billing Team will also be closing today at 12PM.

We appreciate your patience as we assist you. If there are any outstanding concerns, we will reach back out to you as soon as we return.
Posted Sep 05, 2018 - 09:14 CDT
This incident affected: Volusion Platform (Merchant Dashboard).