Phone System Outage
Incident Report for Volusion
Resolved
Phones are back up and functional at this time although we are experiencing higher hold times due to the outage experienced.
You can view https://status.twilio.com/ for more information.
Posted Oct 18, 2016 - 14:29 CDT
Identified
We are currently experiencing issues with our phone system and are unable to receive calls at this time. To submit a ticket please visit: https://my.volusion.com/Create_Ticket.aspx or open a chat with one of our support representatives.

You can check on the status of our provider by going to their Status page: https://status.twilio.com/
Posted Oct 18, 2016 - 14:22 CDT