Customer Experience Team Meeting
Incident Report for Volusion
Resolved
The meeting is over. Please continue to use the phones as usual.
Posted 6 months ago. Jan 03, 2018 - 14:22 CST
Identified
We are hosting a meeting for our Customer Experience team between 12:45 pm CST to 2:15 pm CST. During this time our Billing and Support team will be unavailable. We appreciate your patience along with providing us the ability to meet as a team.
Posted 6 months ago. Jan 03, 2018 - 11:06 CST