Company Wide Meeting
Incident Report for Volusion
Resolved
Thank you for your patience during our company-wide meeting, all phone queues are back to their normal operations!
Posted Oct 14, 2016 - 16:19 CDT
Identified
We will be having a company-wide meeting between 3:20pm to 5:00pm CST. Our billing and support phone queues will be closed to allow our employees to attend. During this time, if you’re experiencing any issues, please log in to your myVolusion account and submit a ticket with details or we are available via chat. Thank you for your understanding.
Posted Oct 14, 2016 - 13:50 CDT