Rackspace Webmail
Incident Report for Volusion
Resolved
Rackspace Webmail
Rackspace has reported the issue as resolved.
Posted Oct 14, 2016 - 22:15 CDT
Investigating
Rackspace is currently experiencing an issue with Webmail and OWA (Outlook Web Access). Anyone using either of those may experience latency or errors when trying to access the Webmail portal. It is suggested to use email clients and mobile devices in the meantime. We will provide an update when we can.
Posted Oct 14, 2016 - 09:43 CDT