Company-wide Meeting
Incident Report for Volusion
Resolved
Our meeting has concluded and all support queues have returned to normal operation. Thank you for your patience.
Posted 11 months ago. May 23, 2017 - 17:10 CDT
Investigating
We are hosting a company-wide meeting between 2:30pm CST to 5:00pm CST. During this time our phone support will be unavailable. We appreciate your patience along with providing us the ability to meet as a team.
Posted 11 months ago. May 23, 2017 - 14:36 CDT