Inclement Weather January 16, 2018
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted Jan 17, 2018 - 08:13 CST
Identified
Due to weather conditions in Austin, Texas, and for the safety of our employees, our Support Team will be unavailable by phone Tuesday January 16th. If you need immediate assistance, we will have limited help available through our in-app messaging. We appreciate your understanding.
Posted Jan 15, 2018 - 18:47 CST