Phone Support Issues
Incident Report for Volusion
Resolved
Our third party provider has successfully completed their maintenance. All phone agents are now operational. If you have any questions, please reach out to our support team
Posted 20 days ago. Oct 03, 2017 - 22:48 CDT
Investigating
We are currently having an issue with receiving phone calls due to a maintenance with our third party provider. In the meantime, if you need to talk to Support, please contact them via the chat feature. We will provide updates when we get them.
Posted 20 days ago. Oct 03, 2017 - 20:41 CDT