Password Reset Emails
Incident Report for Volusion
Resolved
If you are still experiencing issues with accessing your store, please reach out to us at 1.800.646.3517 and we would be happy to help you login.
Posted May 07, 2018 - 11:21 CDT
Investigating
We have received reports that some of our Founders are not receiving Password Reset Emails for stores or my.volusion.com accounts. If you are having trouble getting into your account or resetting your password for either of these logins, please reach out to us at 512.215.5650 for guided assistance.
Posted Apr 25, 2018 - 13:09 CDT