Company Wide Meeting
Incident Report for Volusion
Resolved
Our company-wide meeting has concluded and our phone and messenger services are now fully open. Thank you for your patience.
Posted 10 days ago. Aug 11, 2017 - 11:10 CDT
Identified
We are hosting a company-wide meeting between 9:15am CST to 10:45am CST. During this time our phone services will be unavailable, but our in-app messenger will remain open. We appreciate your patience along with providing us the ability to meet as a team.
Posted 10 days ago. Aug 11, 2017 - 09:28 CDT