Email Issues
Incident Report for Volusion
Resolved
This issue is now resolved.
Posted Jul 02, 2018 - 23:12 CDT
Investigating
We are currently investigating reports of email notifications not being received.
Posted Jul 02, 2018 - 21:44 CDT
This incident affected: Volusion Platform (Email Services).