Phone Support Issues
Incident Report for Volusion
Resolved
Our third party provider has successfully resolved the problem. All phone agents are now operational. If you have any questions, please reach out to our support team.
Posted 20 days ago. Oct 03, 2017 - 16:31 CDT
Monitoring
Our phone service provider has reportedly resolved the issue and is monitoring for stability. You may resume calling in but if you do encounter phone issues, please utilize the chat feature and let Support know. Updates will continue to be made available as we get them.
Posted 20 days ago. Oct 03, 2017 - 16:06 CDT
Investigating
We are currently having an issue with receiving phone calls. We are working with our third party provider to address the issue. In the meantime, if you need to talk to Support, please contact them via the chat feature. We will provide updates when we get them.
Posted 20 days ago. Oct 03, 2017 - 15:51 CDT