Inclement Weather Dec 8, 2017
Incident Report for Volusion
Resolved
Thank you for your patience, our Support Team is now available through all queues.
Posted about 1 month ago. Dec 08, 2017 - 11:01 CST
Monitoring
Due to weather conditions in Austin, Texas, and for the safety of our employees, our Support Team will be unavailable until 10:15 am CDT. If you need immediate assistance, we will have limited help available through our in-app messaging. We appreciate your understanding.
Posted about 1 month ago. Dec 07, 2017 - 23:28 CST