Phone Issues
Incident Report for Volusion
Resolved
Our third party provider has successfully resolved the problem. All phone agents are now operational. If you have any questions, please reach out to our support team.
Posted 25 days ago. Sep 28, 2017 - 19:57 CDT
Identified
Our third party provider has identified the problem and is currently working towards a resolution. Most phone agents should be operational now. If you are still unable to reach support by phone, please reach out through Intercom.
Posted 25 days ago. Sep 28, 2017 - 19:18 CDT
Investigating
We are currently experiencing issues taking phone calls. Our third party provider is working diligently to resolve the problem. If you need to contact support please reach out through intercom.
Posted 25 days ago. Sep 28, 2017 - 17:05 CDT