Sagepay
Incident Report for Volusion
Resolved
The issue with Sagepay integration has been resolved. A fix was deployed and is operational. If you experience any issues with this integration, please contact our Support Team.
Posted Oct 14, 2016 - 13:52 CDT
Identified
We have identified an issue caused by a new integration change made by Sagepay and are actively working on implementing a fix to resolve the issue.
Posted Sep 01, 2016 - 18:18 CDT