Company Wide Meeting
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted 4 months ago. Dec 15, 2017 - 10:47 CST
Identified
We are hosting a company-wide meeting between 9:15am CST to 10:45am CST. During this time our phone services will be unavailable, but our in-app messenger will remain open. We appreciate your patience along with providing us the ability to meet as a team.
Posted 4 months ago. Dec 15, 2017 - 08:48 CST