Possible Slowness
Incident Report for Volusion
Resolved
The internet backbone provider's issue has been resolved. Website speed and functionality has been restored.
Posted Sep 23, 2016 - 10:46 CDT
Identified
We have identified the issue and have determined that the slowness is deriving from the internet backbone providers, not our internal network. We will continue to monitor the situation and update our status as more information is available.
Posted Sep 19, 2016 - 17:32 CDT
Investigating
We are currently investigating reports of site slowness. We will update the status page again as soon as the issue has been determined.
Posted Sep 19, 2016 - 16:19 CDT