All Hands Meeting
Incident Report for Volusion
Resolved
This incident has been resolved.
Posted Jan 13, 2017 - 10:47 CST
Identified
We are hosting a company-wide meeting between 9:00am CST to 10:45am CST. During this time our phone services will be unavailable, but our chat queues will still be open. We appreciate your patience along with providing us the ability to meet as a team.
Posted Jan 13, 2017 - 08:47 CST