Volusion Support Team Outing
Incident Report for Volusion
Resolved
Volusion Support Team Outing

Our support team returned from their outing at 4 pm and have transitioned to returning service to normal levels. We appreciated your patients during the team outing which allowed our support team to attend the event.
Posted Jun 22, 2017 - 17:19 CDT
Investigating
Our Volusion Support team will be away from 12 pm - 4 pm CST for a team building event. Members from other teams in the company will be available during this time to help answer your questions. If there are any outstanding concerns, we will reach back out as soon as we return. Thank you for your patience and allowing our team this opportunity.
Posted Jun 22, 2017 - 10:37 CDT