Phone Issues
Incident Report for Volusion
Resolved
The issue with our phone system has now been resolved.
Posted Aug 23, 2016 - 13:48 CDT
Identified
The issue with our phone system has been identified and call services are currently available. We will continue to monitor the situation.
Posted Aug 23, 2016 - 13:33 CDT
Investigating
We are currently experiencing an issue with our phone system. If you are unable to get a representative on the phone please use our ticket or chat system until this issue is resolved. We will post an update as soon as one is available.
Posted Aug 23, 2016 - 12:58 CDT